Centos7 升级高级版本FFmpeg

背景:

centos默认安装的是2.8.15低级版本的ffmpeg,最新去到4.4左右 因此做视频推拉流来说功能有点不够。 会耗费很多CPU资源因此要升级高级版本

安装步骤:

查看是否安装旧的ffmpeg

FFmpeg-1.png

这里看到是安装了2.8.15版本,我们要将他们卸载干净

yum -y  remove ffmpeg.x86_64  ffmpeg-libs.x86_64 ffmpeg-devel.x86_64

换一个源

yum-config-manager --add-repo=https://negativo17.org/repos/epel-multimedia.repo
yum-config-manager --disable epel-multimedia
yum install --enablerepo=epel-multimedia ffmpeg ffmpeg-devel

FFmpeg-2.png

这样就安装完成了

检查一下是否是4.3.2版本

ffmpeg -version

FFmpeg-3.png

至此就完成了

FFmpeg-4.png

这个是升级之后的进程图

Last modification:April 14th, 2021 at 11:04 am
如果觉得我的文章对你有用,请随意赞赏